Compilando GIMP 2.7

15/05/2010 en 19:00 | Publicado en Aplicaciones, GIMP, Imagen, Linux, Software, Software Libre | 2 comentarios

En este artículo vamos a aprender a compilar nosotros mismos la versión 2.7 de GIMP (marcada como versión de desarrollo que marca el camino hacia la versión 2.8). Podemos descargar el código fuente de la aplicación aquí (el archivo a descargar es gimp-2.7.0.tar.bz2), aunque como vemos en los comandos de abajo, va a ser descargado automáticamente.

Debemos exportar algunas variables de entorno para poder realizar laa compilación:

export PATH=$PATH:/opt/gimp-2.7/bin
export PKG_CONFIG_PATH=/opt/gimp-2.7/lib/pkgconfig
export LD_LIBRARY_PATH=/opt/gimp-2.7/lib

Si estamos en Ubuntu podemos instalar los paquete mas importantes de la siguiente forma:

sudo apt-get build-dep gimp

Si estamos usando cualquier otra distribución que no sea Ubuntu, tendremos que instalar las dependencias una a una de cualquier otra forma. Estas dependencias son:

  • pkg-config
  • initltool (>= 0.40.1)
  • GEGL (>=0.1.0)
  • babl (>=0.1.0)
  • GLib (>= 2.20.0)
  • Pango (>= 1.20.1)
  • cairo
  • PangoCairo
  • dbus-glib

Algunas de las librerias opcionales para los posibles plugins son: lcms, libpng, libjpeg, libpoppler, libtiff, webkit, libmng, librsvg and libwmf.

Ahora pasamos a instalar algunos paquetes adicionales que son necesarios para continuar con la instalación de GIMP:

sudo aptitude install checkinstall git-core libtool
libopenexr-dev libopenraw-dev libspiro-dev

En el caso de estar usando Ubuntu 9.10 o superior las librerías de Glib y Gtk estarán ya instaladas en la versión oportuna. En el caso de que tengamos una versión anterior, deberemos instalarlas manualmente.

Para empezar crearemos una nueva carpeta temporal para poder realizar las instalaciones de las dependencias, y posteriormente cambiaremos al directorio actual a este.

cd ~
mkdir -p tmp
cd tmp

A continuación, vemos todos los pasos para instalar las dependencias:

# Descarga, compilación e instalación BABL
git clone --depth 1 git://git.gnome.org/babl
cd babl
./autogen.sh --prefix=/opt/gimp-2.7
make -j3
sudo make install -j3
cd ..
# Descarga, compilación e instalación de GEGL
git clone --depth 1 git://git.gnome.org/gegl
cd gegl
./autogen.sh --prefix=/opt/gimp-2.7 --disable-gtk-doc
make -j3
sudo make install -j3
cd .. 
# Descarga, compilación e instalación de GIMP
git clone --depth 1 git://git.gnome.org/gimp
cd gimp
./autogen.sh --prefix=/opt/gimp-2.7 --disable-gtk-doc
make -j3
sudo make install -j3
cd ..

Para ejecutar GIMP simplemente ejecutamos el comando:

/opt/gimp-2.7/bin/gimp-2.7

Para poder ver GIMP en el modo ventana única simplemente debemos acceder al menú “Windows -> Single-Window mode”.

Enlace: http://www.gimpusers.com/news/2009-10-14/compiling-gimp-27-git-ubuntu-904-910.html

Anuncios

Limitar el uso de la CPU con cpulimit

15/05/2010 en 16:45 | Publicado en Administración de sistemas, Aplicaciones, Linux, Software, Software Libre, Ubuntu | 3 comentarios

Muchas veces queremos limitar el uso de un proceso en concreto para evitar que este ocupe un porcentaje mas alto de CPU del necesario. Para estos casos podemos utilizar una maravillosa aplicación: cpulimit.

Para instalar en Ubuntu, como siempre:

sudo apt-get install cpulimit

Para usarlo, la mejor manera es empezar llamando al comando top desde una terminal para averiguar tanto el pid como el uso de CPU de los procesos activos del sistema.

Una vez obtenido el pid de la aplicación deseada, el uso del comando es el siguiente:

sudo cpulimit -p PID -l LIMITE

Tomando como ejemplo la salida del comando top, podemos limitar el uso de cpu para el proceso 1528 al 20%.

sudo cpulimit -p 1528 -l 20

8 reproductores de audio ligeros para Linux

07/04/2010 en 01:45 | Publicado en Aplicaciones, audio, Linux, reproductores audio, Software, Software Libre, Ubuntu | 5 comentarios

Hoy os traemos unos cuantos reproductores de audio ligeros para que disfruteis de ellos en vuestra distribución de linux preferida sin tener que consumir muchos recursos para ello.

Music Player Daemon

MPD es una aplicación servidor flexible y potente para poder escuchar música. A través de sus plugins y librerías puede leer gran variedad de ficheros de audio mientras es controlado por medio de su protocolo de red. Así realmente, MPD es un servidor que puede ser controlado por medio de los distintos clientes que se ofrecen para poder manejar remotamente la lista de reproducción de este.

Podemos ver algunos de los posibles clientes para conectarnos al servidor en la lista que tenemos en esta dirección: http://mpd.wikia.com/wiki/Clients.

Guayadeque

Este es uno de mis favoritos. Guayadeque es muy intuitivo y bastante ligero. Sorprende sobretodo su gran cantidad de opciones y su rica interfaz con tan poco consumo.

Bluemindo

Este proyecto pretende conseguir un reproductor de audio muy simple que está desarrollado bajo PyGTK sin ninguna dependencia de GNOME. El objetivo principal de este reproductor es reproducir música (ni mas, ni menos).

Decibel Audio Player

Actualmente es el que yo estoy usando. El mas simple de todos. Si solo quieres escuchar música sin tener que mantener largas colecciones de ficheros de audio, este es el tuyo. Simplemente magnífico.

Consonance

Nació como una idea de un participante de los foros de Arch Linux de desarrollar un reproductor de audio ligero y rápido. Usa las librerías GTK+ por lo que se integrará a la perfección con los escritorios GNOME.

Listen Music Player

Listen Music Player es un reproductor de audio escrito en Python. También puede ser usado para organizar las colecciones de audio. Algunas de sus características mas interesantes son el acceso a letras de las canciones, lastfm o entradas en la wikipedia.

Quod Libet

Reproductor de música escrito en Python (parece ser que es el lenguaje predominante) usando las librerías GTK+ y que utiliza el proyecto Mutagen para las etiquetas de los archivos. Permite realizar colecciones de música conforme a expresiones regulares.

Khövsgöl

Interesante reproductor de audio minimalista y altamente configurable que puede manejar perfectamente grandes colecciones de música. A pesar de que, como casi todos los demás, está diseñado para GNOME, puede funcionar perfectamente en cualquier otro entorno.

Posibles modificaciones en el área de notificaciones de GNOME 3

05/04/2010 en 15:27 | Publicado en Aplicaciones, Desarrollo, GNOME, GNU, Linux, Software, Software Libre, Ubuntu | 1 comentario

Después de que Gnome 2.30 haya sido lanzado hace unos días (última versión antes de GNOME 3, el cual incluirá el esperado GNOME Shell), podemos ver unos mockups de lo que podría ser el nuevo área de notificación de GNOME 3 con un diseño muy minimalista y renovado. A continuación podemos ver algunas de las imágenes de lo que podría ser esta nueva versión:

En mi opinión me parece un cambio muy acertado, y esperemos que nos sorprendan con esto, o incluso con algo mejor.

Fuente: webupd8

¡Ya estamos en twitter también!

31/03/2010 en 16:09 | Publicado en Hablando de Linux, Internet, Linux, red, redes, Twitter | Deja un comentario

Pues como bien dice el título, ¡ya tenemos página en twitter! Así, que si quereis seguirnos a través de twitter nada mas que teneis que entrar en nuestra página: http://twitter.com/hablandodelinux.

Intentaremos llevar sincronizada la publicación de artículos tanto aquí como en twitter para que podais seguir el blog como mas os guste.

Instalando Ruby on Rails en Ubuntu

30/03/2010 en 02:26 | Publicado en Administración de sistemas, Aplicaciones, Cloud Computing, Desarrollo, Internet, Linux, Programación, ruby, Software, Ubuntu | Deja un comentario

Últimamente me ha llamado la atención la dirección que están llevando los desarrollos webs (sobretodo gracias al Cloud Computing), así que me decidí a aprender un poco sobre desarrollo de aplicaciones web (nunca lo había tocado a excepción de un poco de HTML). Luego de probar un poco de PHP, descubrí el framework Ruby on Rails para el lenguaje Ruby. Por ahora he probado poco y sé poco del framework en si (estoy primero intentando aprender un poco de ruby a marchas forzadas).

Para instalar Ruby on Rails en Ubuntu tenemos que seguir varios pasos ya que no solo necesitamos el intérprete de ruby.

Primero, instalaremos el intérprete de ruby y sus complementos:

sudo apt-get install ruby-full irb

Luego tendremos que instalar la base de datos MySQL, así como las librerías correspondientes al lenguaje ruby para poder manejar la base de datos:

sudo apt-get install mysql-server libmysql-ruby

Para poder terminar la instalación del cliente de mysql tendremos que establecer una contraseña para el usuario root.

Y como último paso instalaremos el framework deseado: Ruby on Rails. Para ello podemos instalarlo con rubygems o bien instalarlo como hemos instalado los demás requisitos: con apt-get.

sudo apt-get install rails

Ahora debemos probar que la instalación ha sido completamente correcta. Para ello, abrimos una terminal y creamos un proyecto de Ruby on Rails de la siguiente forma:

rails nuevoproyecto

Para poder probar que se ha creado correctamente, simplemente ejecutamos el script que lanza el servidor:

cd nuevoproyecto ruby script/server

Por último abrimos el navegador e ingresamos la dirección http://localhost:3000 y debería aparecer un mensaje de bienvenida de Ruby on Rails parecido al que aparece en la imagen de abajo.

Fuente: http://www.ubuntu-ve.org/node/501 / http://www.pablasso.com/2009/01/12/%C2%BFcomo-instalar-ruby-on-rails-en-ubuntu

Twitter desde el escritorio con Pino

20/03/2010 en 18:40 | Publicado en Aplicaciones, GNOME, Internet, Linux, red, redes, Software, Software Libre, Twitter, Ubuntu | Deja un comentario

He encontrado una interesante aplicación para los grandes seguidores de Twitter. Estamos hablando en este caso de Pino. Aunque hace poco ha sido incluida en los repositorios de Ubuntu la aplicación Gwibber, aquí traemos esta curiosa y liviana aplicación escrita en lenguaje Vala (tengo mucha curiosidad por este lenguaje, asi que puede ser que próximamente haga algún artículo sobre él) como una interesante alternativa.

Para poder instalar en Ubuntu simplemente tenemos que añadir los repositorios de Pino, actualizarlos e instalarlo:

sudo add-apt-repository ppa:vala-team/ppa
sudo add-apt-repository ppa:troorl/pino
sudo apt-get update
sudo apt-get install pino

Aquí tenemos una captura de la aplicación en funcionamiento:

Mejoras en la nueva versión de VLC 1.1.0

17/03/2010 en 00:48 | Publicado en Aplicaciones, Desarrollo, GNOME, Linux, Software, Software Libre, Ubuntu, Video | Deja un comentario

Podemos leer en muylinux.com algunas de las nuevas características de la nueva versión de VLC (1.1.0). Al parecer, este nuevo lanzamiento va a tener algunas novedades interesantes a tener en cuenta:

  • Decodificación de videos a través de la GPU: Usando VAAPI en Linux será posible el uso de la decodificación por medio de la GPU liberando así al procesador de una gran cantidad de carga de trabajo. Por supuesto, tendremos que tener una gráfica compatible con este modo de funcionamiento.

  • Mejora en la decodificación por parte de la CPU: Este aspecto ha afectado mayormente a la versión de Windows.

  • Decodificación DSP con códec OpenMax IL en Linux embebidos como Maemo: Mejora tanto en consumo como eficiencia en la codificación.

  • Mejora en el pipeline de audio.
  • Menor consumo de RAM.

Así que por lo que podemos ver esta nueva versión de VLC va enfocada mayormente hacia los contenidos en alta definición y una mayor eficiencia en general.

GNOME Media Player, un frontend para VLC al gusto de los usuarios de GNOME

17/03/2010 en 00:31 | Publicado en Aplicaciones, Desarrollo, Entornos de escritorio, GNU, Linux, Software, Software Libre, Ubuntu, Video | Deja un comentario

Si no estais del todo conformes con como se integra la interfaz gráfica del maravilloso reproductor VLC con vuestro escritorio GNOME estais de enhorabuena. Ahora tenemos disponible (aún en fase temprana de desarrollo) el proyecto GNOME Media Player.

Actualmente, el proyecto tiene las siguientes características:

  • Interfaz GNOME/GTK
  • Fullscreen con doble-click
  • Puede usar el scroll del ratón
  • Usa libvlc o xine-lib
  • No tiene control de volumen
  • Botón intermedio del ratón para pausa

Para poder instalarlo en Ubuntu simplemente tendremos que recurrir a los repositorios de launchpad (en los que además ya tenemos disponible el paquete para Ubuntu Lucid).

sudo add-apt-repository ppa:gnome-media-player-development/development

Posteriormente tendremos que hacer una actualización de los repositorios e instalarlo mediante apt-get como siempre:

sudo apt-get update && sudo apt-get install gnome-media-player

Para poder acceder a él solo tendremos que ir al menú Aplicaciones > Sonido y video > GNOME Media Player.

Como saber que paquete ocupa mas en nuestro Ubuntu

17/11/2009 en 17:02 | Publicado en Administración de sistemas, Linux, script, Software, Ubuntu | Deja un comentario

Leo en Ubuntu Life un interesante tip que nos permite saber cuales son los paquetes que están ocupando mas espacio actualmente en nuestro sistema. Este comando sería el siguiente:

dpkg-query --show --showformat='${Package;-50}\t${Installed-Size}\n' | sort -k 2 -n | grep -v deinstall | awk '{printf "%.3f MB \t %s\n", $2/(1024), $1}'

¿Cuales son los paquetes que os ocupan mas a vosotros?

Página siguiente »

Crea un blog o un sitio web gratuitos con WordPress.com.
Entries y comentarios feeds.